MG & Rover - XPower Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
173 Posts
Discussion Starter #1
I'm on my second MG ZS 180, the first car I bought blew up after 4000 miles. The manufacturer and the dealer missed the fact that there was no oil in the car. I'm still amazed thet it went for so long without so much as a miss sounding tappet.

I have been reading the other threads about the oil consumption. I find my ZS drinks about half a litre every thousand miles. Has anyone else experience problems such as these. The oil pressure light does not seem to work and I'm finding the oil levels a little baffling at times.

I live in Cambridge, does anyone else own an MG ZS here. I've not seen a single car since I bought mine in September.
 

·
MG ZT-T 190
Joined
·
6,716 Posts
I'm in Cambridge.
There are a couple of other cambs people on here!
I have blue ZS, I think there is a yellow one in Swavesey, is that you?

Kelvin
 

·
Registered
Joined
·
388 Posts
Clay said:
I live in Cambridge, does anyone else own an MG ZS here. I've not seen a single car since I bought mine in September.
I live in Cambridgeshire and trundle ;) into Cambridge a couple times a week or so in my ZS180. I saw a Trophy Yellow ZS180 driving through the centre of Melbourn the other lunchtime - it certainly stood out! :)

S.
 
G

·
Clay said:
I have been reading the other threads about the oil consumption. I find my ZS drinks about half a litre every thousand miles. Has anyone else experience problems such as these. The oil pressure light does not seem to work and I'm finding the oil levels a little baffling at times.
Hi Clay

Doesn't the OIL LP light illuminate - before engine start? If it does then you have low pressure until the engine builds pressure to extinguish it. If this is not the case - then if it was my ZS180 - it wouldn't move until fixed - especially after being bitten once. :( Why - no warning of oil pressure loss. :(

MY KV6 R75 that Matt runs never consumed any oil of note.
 

·
Registered
Joined
·
173 Posts
Discussion Starter #6
What no oil?

The oil light goes out straight away after the key has been turned. I'm a little concerned and have booked it in for the 5th time. I do travel allot and have clocked up 16,000 miles in six months. I don't really push the car and it is all motorway mileage. 32,000 miles a year is not excessive by any means.

MGR never really gave me an explanation of the original fault. It took MGR 2 month to replace my car and as you can imagine I was not at all happy. Even when MGR replaced the car it was not a brand new replacement, it had over 500 miles on the clock. MGR did not even give me a replacement MG to drive in the mean time (Rover 45TD with a big dent in the wing)

I love the car, but as with all dealers and manufacturers they are never quick to admit failure and unfortunately its always the customer who suffers. I had a terrible time trying to get a new car from MG and they simple refused to replace the car, only offering an engine replacement and free servicing for 5 years. The dealer gave me their demo car in the end, but as I mentioned it was technically used having 500 miles on it.

Thanks for your interest
 
1 - 6 of 6 Posts
Top