MG & Rover - XPower Forums banner
1 - 20 of 27 Posts

·
Registered
Joined
·
295 Posts
Discussion Starter · #1 ·
Bet you think this is going to be about them damn VIS motors.... well it's not! (well maybe it is but we will see)


Coming home from work today I noticed a small ticking sound, it only happens when I roll off the power while moving. Stationary there is no sound, stationary revving also produces no ticking, accelerating makes no ticking, but if I roll off with the clutch up there is a ticking, if I push the clutch down the ticking stops, similarly if I take it out of gear and allow to roll there is no ticking. Any ideas what this could be?
The clutch was changed a month or so ago (a story in its self which I will post some other time) and has not had this happen before!

So once again I find myself throwing myself at the feet of the great people on here! :unworthy:

Rusty
 

·
Registered
Joined
·
516 Posts
My wife who drives our ZS 120 most of the time reported a similar 'clicking' a while back. I tried the car and all appeared well but the clutch pedal action did not feel as nice as it normally was.

Few days later my wife started the car ready to drive to her office and could not engage a gear. Long story short, the clutch release bearing had completely broken up. Not a pretty sight .. :(





Fitted a new clutch and the car has a nicer clutch now than when we had it new. A delight to use :~



Mention of VIS suggests yours is a 180 so maybe something as Monty Python would have it .. Completely different ... in view of other information you provide.

P.S. Look forward to follow up "A story in itself " reference the recent clutch change.
 

·
Audi S4 500HP
Joined
·
6,659 Posts
I've had this after a clutch change(buy a reputable guy on here).

It went away after a few weeks,but I knew he'd done things by the book so wasn't worried after speaking to him
 

·
Registered
Joined
·
9 Posts
does it sound like a relay ticking? i had this a few months back, it was the ABS relay and turned out i had 2 abs rings gone, changed them and the ticking has now stopped :)
 

·
Registered
Joined
·
398 Posts
does it sound like a relay ticking? i had this a few months back, it was the ABS relay and turned out i had 2 abs rings gone, changed them and the ticking has now stopped :)
I want some pictures of your car!!!!!!!!


Doubt it's anything to do with INLET MANIFOLD!! VIS motors don't click....
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #6 ·
I think the car is trying to **** me off (I just don't think it wants to go over the 100,000 mile mark, 99,569 and counting);
So on the way home today the noise now appears to come on a neutral throttle as well, but still not while accerating. When I got home I had a look under the bonnet to see if I could hear anything and noticed the noise was lower down, so under the car I went, and what did I find..... a few drops of oil on the floor and oil dripping down :agh: (see pics below) Now I can't work out where the oil is coming from as it's not visible from above and too dark now to be poking around, or even whether it's related to the ticking noise......... :bh (on a small upside means I can take the motorbike into work!)

MGJohn - I really hope that's not the case, as I found out it's a big job getting in there! Did it do any damage? Also yes it's a 180, sorry should have put that in the OP.

shroonie29 - Do you know what caused it?

k7ngt - at first I thought it was but not so sure now; I do know that one of the ABS rings is going/gone, just need some time to sort it!

While we are on the ABS rings is it worth doing the back as well? Come to think of it are they even on the back??


as you can see the oil seems to be coming down from the top middle/right of the pic!



Once again thanks for the help!
 

·
Registered
Joined
·
2,442 Posts
The over braid on the exhaust looks past its best, the ticking could be a leak from that area.

Not sure on the oil, could be a cam cover, or cam seal perhaps.

Is it engine oil, the other thing it could be is pas fluid
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #8 ·
Hi Pete, yes the braid is past it's best, but I held onto that with some thick gloves to see if it stopped or changed, but it didn't. I have know about this for a while but has never been a problem, can I just whip it off or is it a needed part?

I'm 90% sure its oil, I only noticed this as the sun was going down.
Rusty
 

·
Registered
Joined
·
516 Posts
On Rover T-Series engines such as fitted in my 620ti, if the Exhaust Manifold Gasket starts to wear allowing exhaust gasses to escape, that can sound remarkably 'metallic' like a small hammer being tapped rapidly on and anvil.
.
 

·
Commission Number 000744
Joined
·
2,651 Posts
I had a dog once that went tick tick tick - he was a watch dog.


:sofa::getcoat:
 

·
Registered
Joined
·
516 Posts
I had a dog once that went tick tick tick - he was a watch dog.


:sofa::getcoat:
.........
for G-G ... ;)
..
.... and I bet your dawg had no nose. So how did he smell ?

Summut awful !................. :D
 

·
Commission Number 000744
Joined
·
2,651 Posts
.........
for G-G ... ;)
..
.... and I bet your dawg had no nose. So how did he smell ?

Summut awful !................. :D
I was going to answer straight away but then decided to be like my dog...








Big paws!
 

·
R.I.P [The Red Zed] MG ZS 180
Joined
·
19,410 Posts

·
Registered
Joined
·
295 Posts
Discussion Starter · #19 ·
What do you call a dog with no ears?


Call it what ever you want it can't hear you!

Yer I know not the best.... but seems to fit nicely here :stir::dddc:

Anyway big pool of oil this morning, but still can't see where it's coming from!
 

·
Commission Number 000744
Joined
·
2,651 Posts
An actual OT post from me -

Theres ABS rings on the back but they are hidden behind discs and not exposed, don't think they tend to go like the fronts do.

Gotta lie down now...
 
1 - 20 of 27 Posts
Top