MG & Rover - XPower Forums banner

1 - 8 of 8 Posts

·
pricey
Joined
·
68 Posts
Discussion Starter #1
Hello I have 2 zs's a mk1 and mk2 on both of them the airbag lights
have come on as well as other lights sometimes :/ Im guessing this is a common fault on the Mgs? Is this easy fixed? Cheers
 

·
YELLOW PERIL
Joined
·
2,407 Posts
Had this on my MK2 derv, if you look under the front pass seat there is a wire connection, I sprayed some WD4O over it and gave it a quick wriggle about. Fixed it for a few months, came back on, another wriggle and pull and its been OK since. Year and a half but now I've put the curse on it and next time I go out the SRS light wont!!!

:wave
 

·
Registered
Joined
·
1,545 Posts
as pete says its usually the connectors under the front seats(both seats) if you dont hae any contact cleaner usually just splitting the plug and reconnecting is enough to give the conections a clean, then the light should automatically go out, found if stuff is under your seat rolling about into the the cables can cause it to come on as well
 

·
pricey
Joined
·
68 Posts
Discussion Starter #4
Ok cheers guys I'll give a go In a bit and see if It works :)
 

·
Registered
Joined
·
259 Posts
can it fail the mot as mines on permanantly and i havnt got round to sorting it yet?????????????????
 

·
R.I.P [The Red Zed] MG ZS 180
Joined
·
19,410 Posts
I am not sure about this but if the light is on the Air Bags are disabled so possibly an advisory but i probably am wrong
 

·
Registered
Joined
·
63 Posts
suppose it depends on where you go for the mot but my rover 200 passed its mot today with the srs light on and the abs light on as they are both disconected
 
1 - 8 of 8 Posts
Top