MG & Rover - XPower Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
368 Posts
Discussion Starter #1 (Edited)
I was turning from a junction onto a sharp left u-turn (up an incline) and as I put the power on I got a bit a jolt and a slight bang (I thought it might have been a bit of wheel spin at first). Further down the road I can now hear a horrible squealing noise so pull over to have a look but can't see anything obvious. Start going again and the noise is worse, like a squeal of metal on metal (sounds like a train stopping at the platform!). I think it might have been coming from passenger side but it was hard to say. I'm thinking now of just pulling over and calling breakdown people as I'd still got to negotiate a 20 mile stretch of the A19 but then after stopping and starting driving again the noise stops and I got all the way home without hearing it again.

Any ideas what it was?
 

·
YELLOW PERIL
Joined
·
2,407 Posts
Could it have been a stone trapped under the front disk/pad.

We had a Metro and after gritting the road, the wife left the car at the side of the road, complaining of a noise.

I jumped in and it sounded like there was a spade dragging along under the car, backed it up and put the brakes on and the noise went.

:wave:
 

·
Registered
Joined
·
368 Posts
Discussion Starter #3
Hi Peter, hope that's all it was and nothing's broken. Just didn't understand the slight jolt and pop.
 

·
YELLOW PERIL
Joined
·
2,407 Posts
The noise started when the wife had taken the car out with her driving instuctor. He refused to carry on with the lesson and they had to walk back to his car.

I thought what a whimp, jumped in the car and the noise was horrid, just like you were dragging a spade along under the car. Could see why he didnt want to drive on.

Any way, I stopped, looked under the car, nothing. Started it up, still the same noise going forward, so I went backwards fairly fast and hit the brakes. Must have cleared it and it was OK.

Hope that was all yours was, the bump and pop could have been something getting between the pad and disk.

:wave:
 

·
Registered
Joined
·
615 Posts
Had this on mine a couple of times, turned out to be the brake disk shielding plate fouling the inside of the disc, a truly horrifying sound it makes too.
 

·
R.I.P [The Red Zed] MG ZS 180
Joined
·
19,410 Posts
We also had this on the RedZed
 

·
Registered
Joined
·
368 Posts
Discussion Starter #7
In the cases above where it wasn't a stone, what remedial action was required (if any)?
 

·
R.I.P [The Red Zed] MG ZS 180
Joined
·
19,410 Posts
In the cases above where it wasn't a stone, what remedial action was required (if any)?
Push the brake disk shielding plate away from the disk.
 

·
Learned member
Joined
·
1,389 Posts
In the cases above where it wasn't a stone, what remedial action was required (if any)?
Check your rear pads, the wear indicator makes a terrible noise when it starts rubbing on the disk.
 
1 - 9 of 9 Posts
Top