MG & Rover - XPower Forums banner
1 - 8 of 8 Posts

·
Premium Member
Joined
·
7,145 Posts
Discussion Starter · #1 ·
Is it an MOT failure?
 

·
Registered
Joined
·
3,492 Posts
It will be from 1st April if it isn't already.

Do you know why it is on?

Can it be cleared by a reset?

Is there anyone near with a scanner, I'd happly do it, it only takes a few seconds but I don't think you are in north West Sussex.
 

·
Registered
Joined
·
123 Posts
had this on a city rover not so long a go as long as it is with in the emissions it is ok was at my mot station make sure good and hot and a clean air filter helps if you know someone with a plug in thay should be able to turn it off
 

·
Registered
Joined
·
1,319 Posts
Is it an MOT failure?
The light itself won't fail you. The thing that's causing it light up might though; especially if it's emissions related. Tbh, I don't know exactly what the MIL light is supposed to monitor. I'd be interested to find out though.
 

·
Premium Member
Joined
·
7,145 Posts
Discussion Starter · #6 ·
It will be from 1st April if it isn't already.

Do you know why it is on?

Can it be cleared by a reset?

Is there anyone near with a scanner, I'd happly do it, it only takes a few seconds but I don't think you are in north West Sussex.
It comes on randomly now and again since the exhaust system was changed. I've always been able to turn it off using the OBD2 but I'm having a problem this time. The OBD2 seems to be having trouble communicating with the car. No fault codes are showing and the MIL is showing as "off".

IIRC, the MIL has come on several times in 4 years of ownership with a P0140 fault code.
 
1 - 8 of 8 Posts
Top