MG & Rover - XPower Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello Hello!

I'm a long time lurker, first time poster here. I've also only recently acquired my first MG and have very little experience of mechanics. I know that my ZT is apparently the model prone to HGF so right from day one I've been vigilant of, well, everything!

Well, my main question is after starting and pretty much whenever my ZT idles, it pulses. I can hear it, feel it and see it on the rev counter (varies about a notch or two). Is this normal? Anything to worry about/get checked out?

I'm also having to top up my water every 2-3 days or so, which is a worry of course. There is no obvious leak I can see but it's going somewhere! I'm not losing any oil at the moment. Although there seems to be a little bit of dryish oil dotted along the engine block seam in patches. Is this a worry? I think I might just be paranoid...

A friend of mine just suggested buying some cooling system sealer but I think I'd rather get it all pressure tested. What do you think? How much would pressure testing reasonably cost? (just don't want to get ripped off!)

This damsel in distress is in need of expert advice!
 

·
Registered
Joined
·
299 Posts
I think a little oil seepage from the block is normal (worse on the left hand side?) The two K series I know have this quirk.

Re: the coolant; this definately doesn't sound right! Is there any steam coming from the exhaust? 'Mayonnaisey' sludge in the expansion tank/under the oil filler cap?
 

·
R.I.P [The Red Zed] MG ZS 180
Joined
·
19,410 Posts
The coolant tank cap may be worth a change.

If after that its no better and you cant see any leaks then get it pressure tested.
 
1 - 3 of 3 Posts
Top