MG & Rover - XPower Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi it seems I have exactly the same problems with my ZT as everyone else has had with the one exception and that is mine still wont start. All other posts seem to have found a fix, but mine still baffles me. Had the car 4 years, no problem. last week fuel ran low i.e. 20 miles left. Went out one morning battery flat, changed the battery, car started then died, started it again, started then died. Since this new battery now fitted, car turns over but will not fire. I have had the fuel pump out and yes it was not as tight as it should have been so this has now been tightened up as well. More fuel added to car, trip meter now shows 105 miles left in the tank, but still the car wont fire. Any suggestions please, I really need the car as I'm stuck without it.

Regards. Brindle
 

·
YELLOW PERIL
Joined
·
2,407 Posts
See its a 2.5, know some have had problems restarting and it seems they need a bit more fuel in the tank, than just one 5 ltr can.

Might be worth putting a few more cans in to see if that helps.
 

·
Its a V8 user thing...
Joined
·
2,122 Posts
Not sure what you are saying here. You have a filter on the near side and the pump on the off side. You need to look at both. If in deed you have looked at the pump then check the filter as that will stop you by allowing air into the system.

Agree sometimes you need a bit of pressure to kick the system off again.

Could check to see you are getting a good amp supply to the plugs, also double check your 'earth' is okay.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Thanks guys for your input. Pete I see your in Bournemouth do you know me, how did you know the car was a 2.5 ? As for my post Tim, yes I did get it wrong, its the filter I had out today, just gonna get some more fuel now, I will let you know if it makes any difference. K
 

·
YELLOW PERIL
Joined
·
2,407 Posts
Thanks guys for your input. Pete I see your in Bournemouth do you know me, how did you know the car was a 2.5 ? As for my post Tim, yes I did get it wrong, its the filter I had out today, just gonna get some more fuel now, I will let you know if it makes any difference. K
Had a look at your "profile", we are over by Castle Point, give me a shout if you want any running around for bits.

:wave:
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Top man Pete, Top man Tim. Went and got some more fuel, and the dam thing started first time. What a crap design this part of this car is, I have never swore as much as I have today.
Pete a second massive thanks for your offer of assistance, I really appreciate your gesture, and I'm still intrigued to know how you know my car is a 2.5 from my profile.

Thanks a lot chaps. Brindle
 

·
YELLOW PERIL
Joined
·
2,407 Posts
Hi, click on your user name, view public profile, then about me.

About brindle
What MGR do you drive?
2.5 ZT
Your Location?
Bournemouth
Socially, what do you like doing most with your MG
Motor-Racing - other?

Glad its sorted. I'll have to start waving at the ZT's!!!

My ones a Mk2 Trophy Yellow ZS, so give us a flash.

:wave:
 

·
Its a V8 user thing...
Joined
·
2,122 Posts
Good to hear you're okay. :)

Top man Pete, Top man Tim. Went and got some more fuel, and the dam thing started first time. What a crap design this part of this car is, I have never swore as much as I have today.
Pete a second massive thanks for your offer of assistance, I really appreciate your gesture, and I'm still intrigued to know how you know my car is a 2.5 from my profile.

Thanks a lot chaps. Brindle
 
1 - 8 of 8 Posts
Top