MG & Rover - XPower Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Hi All,

Having recently had the inlet manifold replaced under warranty, and fitted the excellent sheddist clutch kit to replace some duff OE kit - I am now down to my last issue... (Trying to get everything tip top before a long journey to Paris).

Only actually picked up on this when next to a wall with my window down at a drive through, a fairly horrendous ticking/blowing noise when accelerating in gear (doesn't do it at idle or in neutral when revving the engine).

Engine doesn't sound too bad hydraulic lifter wise, the noise does not really seem to be there until the car is actually in gear and some engine load put on it.

The only thing I can think of is something to do with the exhaust manifolds, either gasket or leak, or a part of the front exhaust system deteriorating - does anyone know if the EM Gaskets were a known issue? Or it might just be the manifolds themselves need tightening up/have worked loose? There is a notable exhaust sound, but having never owned a 180 before i am not sure if it is actually supposed to sound that way.

MPG seem's very slightly down on what it should be, car has always been fully serviced, got the entire stack of history since new, last serviced in January. 64k on the clock, all major service items (cambelts, etc) all done mid last year.

Cheers in advance!
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #5 ·
Thanks for the replies all, I'll get under it at the weekend to inspect the mid section, stuck working for the time being.

As for the Brakes, they seem to all be in good nick but will double check around the area.

It sounds very much like the worn valve guides I had on my old E36 BMW, but that noise was present even when revving free in neutral. That's what got me slightly worried!!
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #6 ·
I wouldn't go so far as to call it a rasp, but its kind of close. It is frustrating the seven hells out of me though!!
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #8 ·
Got it going up on ramps in my friends garage Monday. Hoping too it is the exhaust which is now starting to sound a bit blowy as well.

Thanks for everyone's replies
 
1 - 8 of 8 Posts
Top