MG & Rover - XPower Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
559 Posts
Discussion Starter · #1 ·
Hi all.
I wanted to go away with my car. I used my ladies keys from a car. Battery in key fob dead (think it should be it). So opened car with key. Car alarm started. (my horn is dead so no sound just flashing lights). Then I tryed to start. Nothing happened(imobiliser was on). After closing car with key alarm still on (flashing lights) than stops and goes one more time on. So why this happened? it is very strange than I couldn´t open my car properly with key. Any idea ? thanks.
 

·
YELLOW PERIL
Joined
·
2,407 Posts
Battery in the key fob must be OK.

Key will open the car, but there is a sender unit in the key fob that talks to the car computer and when it recognises that its OK, it will let you start the car.

If the car is a Mark 2 ZS, they can have soggy sounder syndrome, where water gets into the sounder unit. But your problems sound more key fob battery.

Thats the way I think it all works, best of luck with it.

:wave:
 

·
Registered
Joined
·
559 Posts
Discussion Starter · #3 ·
yeah my horn is dead i know, also battery in key fob is dead, but is strange than key coudn´t start car without fob. I love this car one prob. solved another appears .
 

·
Registered
Joined
·
2,387 Posts
The immobiliser won't work without an active fob. So if your fob battery is dead the engine will turn over but the immobiliser will not let it start. Not sure why your alarm is going off though unless you enter the car with just the key from the passenger side as the key only disarms the alarm on the drivers side.
 

·
Registered
Joined
·
1,319 Posts
yeah my horn is dead i know, also battery in key fob is dead, but is strange than key coudn´t start car without fob. I love this car one prob. solved another appears .
You're inventing probs that aren't there....bit like me. It's all in your mind mate! Just put a new battery in the bleedin thing! :)
 

·
Registered
Joined
·
559 Posts
Discussion Starter · #6 ·
how many horns have mk2 , one horn and one alarm horn? or just one
 

·
Registered
Joined
·
559 Posts
Discussion Starter · #8 ·
thanks for help, ordered tf80 magnum stebelt.
 

·
MKII MGZS180
Joined
·
2,314 Posts
When the alarm goes off it should be a siren sound from the sounder unit rather than the horn in the mk2.

If you press the horn button on the steering wheel and it doesn't sound and hear the relay clicking then the horn is broken and will need replacing. Quite normal in a mk2.
 

·
Registered
Joined
·
559 Posts
Discussion Starter · #10 ·
I hear relay, no sound, but my alarm is on (flashing lights) but no sound. I bought that horn and it came (2pcs low and high tone sound siren+ relay) can someone help how to conect it? thanks for reply
 
1 - 10 of 10 Posts
Top