MG & Rover - XPower Forums banner
1 - 16 of 16 Posts

·
bigfella-network.co.uk
Joined
·
5,743 Posts
Discussion Starter · #1 ·
I've been putting up with poor radio signal for some time now. It seemed to work, then it cuts out and fails hold a station for a reasonable amount of time.

I finally bit the bullet and replaced the aerial and cable. Took a couple of hours, you need to drop the passenger side headlining at the front slightly. Cut away the old cabling apart from on the A pillar (useful to attach the new one to). I now have a much improved radio reception.

Attached is a pic of the rotton old cable, it had also been leaking. I used some silicone to make sure the new one sealed and did it up nice and tight to compress the seal and sealant down onto the roof. Worth using some copper grease on the exposed metal too.
 

Attachments

·
bigfella-network.co.uk
Joined
·
5,743 Posts
Discussion Starter · #2 ·
PS sorry I have been inactive these days, not lost interest totally in the car just had other bits and bobs on.
 

·
bigfella-network.co.uk
Joined
·
5,743 Posts
Discussion Starter · #4 ·
Yeah its worth doing. I think some of the copper grease may have "bridged" the shield and signal wire so I will have to remove it on the weekend again. Forgot that copper grease conducts.

I do wonder weather its due to my Alpine tuner not being as good as other brands.
 

·
MG ZT-T 190
Joined
·
6,716 Posts
My radio reception is ok across most channels, but one channel is not so good, and its on FM and its should be a lot better than it is, and that's Radio 2.

Often, (daily) when I stop at traffic lights, the signal really goes, move forward a little and it comes back... the cableing under the road for the traffic lights affects the signal. The solution I guess is choose another channel, but I like Chris Evans in the mornings and Steve Wright in the afternoons on the way home!
 

·
bigfella-network.co.uk
Joined
·
5,743 Posts
Discussion Starter · #7 ·
What headunits do you have?
 

·
Registered
Joined
·
3,492 Posts
Standard MGR fix for poor radio reception in the ZS and ZR was to supply the customer with the long whip from the Rover 25/45. Mine had this when I bought the car (1 P/O), I have recently installed a DAB head unit and a signal splitter from the original aerial and TBH I wasn't expecting much but have been plesently surprised by how good the signal is, 99% fix.

So I guess the question isn't which brand of H/U but which length aerial?
 

·
bigfella-network.co.uk
Joined
·
5,743 Posts
Discussion Starter · #9 ·
I tried that first, had a 45 aerial on it. ****e.
 

·
bigfella-network.co.uk
Joined
·
5,743 Posts
Discussion Starter · #12 ·
All good mate, been going well.

Longtime no speak, how are you and what are you driving?
 

·
YELLOW PERIL
Joined
·
2,407 Posts
When I bought mine the radio would go in and out of the station.

Rather than repalce the whole ariel the garage put on a new multi socket, as they said that was damaged.

Been alright since, so might be worth checking that as well.
 

·
Ex MG ZS 180
Joined
·
353 Posts
All good mate, been going well.

Longtime no speak, how are you and what are you driving?
You I'm good too mate - Not been on here for years though lol.

Changed jobs just over a year ago and now work much closer to home within walking distance. That gave me the opportunity the get my Subaru WRX I'd always wanted. Was very sad to let the old Toledo go though. Never owed me a penny and was a brilliant car. Can't believe you still have the ZS though, especially knowing how quickly you got bored with cars before!!

Sorry to take off topic btw :hammerhea
 

·
bigfella-network.co.uk
Joined
·
5,743 Posts
Discussion Starter · #15 ·
When I bought mine the radio would go in and out of the station.

Rather than repalce the whole ariel the garage put on a new multi socket, as they said that was damaged.

Been alright since, so might be worth checking that as well.
Not sure what multiplug they were talking about. The ISO plugs for the headunit have no bearing on signal strength.
 

·
bigfella-network.co.uk
Joined
·
5,743 Posts
Discussion Starter · #16 ·
No problem Kewe, nice choice of car. The ZS owes me too much to replace now and it does the job pretty well!

Don't worry about off topic, about time this place got a bit of spice about the place. Could do with a spruce up. This black look is a bit gothic for my liking!
 
1 - 16 of 16 Posts
Top