MG & Rover - XPower Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1,539 Posts
Discussion Starter · #1 ·
As far as I am aware, they were both working in the last couple of days. Last night, neither of them come on. My first thought was a fuse, but it appears there is one for each side, numbers 21 and 22.
I'll see about swapping some fuses about, and also hunt down a spare bulb. Will report back when fixed but please feel free to suggest stuff for me to try in the meantime.

I hope it's not the stalk, although I have turned my lights off when indicating as the switch didn't go on fully. Leigh, if you are reading this, PM me if you still have the light stalk please!

MK1 MG ZS.
 

·
Registered
Joined
·
1,539 Posts
Discussion Starter · #5 ·
Both bulbs popped! the filament is actually broken in one. I didn't think they would both go at once, or I've been driving round with one light for a while :s Despite parking nose to a wall. Eep.

Emailed re 12 month warranty with powerbulbs.com I bought these last december. Also bump the MGZS10 discount code again. They aren't teh cheapest but discount + warranty means I'll keep using them if they replace this set. EDIT: I don't work for them, so please don't nail me for advertising. I am jsut sharing the discount :)

On a side note, while playing with fuses i FINALLY found out how to replace/remove the driver's side stoage. you lift it off the bottom pegs and swing it forward, there are teo metal springy metal clips at the top.
 

·
Administrator
Joined
·
10,642 Posts
Yes....I was going to say it will definitely be your bulbs!
 
  • Like
Reactions: Sambo1981

·
Registered
Joined
·
1,539 Posts
Discussion Starter · #7 ·
Yes....I was going to say it will definitely be your bulbs!
OK smartarse, I will literally post you a cookie if you can tell me which bulbs to change for the following not working:
NSR indicator
Both rear fogs

I have changed: Fuses 25 and 17 for a spare. swapped fog light with each other, and swapped both rear indicator bulbs with each other and for new bulbs.

Only one cookie to the first complete correct answer.

Thanks for previous help, rep all round once this is sorted.
 

·
Registered
Joined
·
1,539 Posts
Discussion Starter · #9 · (Edited)
I'll give them a prod...

EDIT: Gave them both a wiggle, they felt solid but I thought i would test anyway and now I have working indicators/hazards.

Still no fogs but that might be the orange bulb out on the switch, or the switch itself. DO the rears only come on when other lights are on?

Ritchy, PM me your address I am sending you a cookie.
 

·
Learned member
Joined
·
1,389 Posts
DO the rears only come on when other lights are on?

Ritchy, PM me your address I am sending you a cookie.
Correct . . . I think you need sidelights at least for rear fogs to come on.
 
1 - 12 of 12 Posts
Top