MG & Rover - XPower Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
295 Posts
Discussion Starter · #1 ·
So I have been hearing a strange knocking from the front N/S, got under there today and the drive shaft is very loose (in/out, side to side and up and down) where it goes into the box, the hub end is solid still. My question is; is there any know common cause for this and how hard is it to replace is somthing is broken in there?

Thanks

Rusty
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #2 ·
Well I took it apart and had a little look around which went fine, putting it back together thought, not so easy.

I have this last ball joint to get tight but can't seem to work it out. When I try to do the nut up the whole joint twists aswell; there doesn't seem to be any way of stopping the joint moving, no allen key at the bottom and the top is not accasable. The Haynes manual says it should just do up.

Does anyone have any ideas what I am doing wrong here?





Thanks again

Rusty
 

·
hyphoooooooo
Joined
·
166 Posts
If you haven't managed to do it yet try:

Use a large bar and try pulling down on top of the ball joint. Putting pressure onto it will help stop it spinning.
or
Or put the jack under the suspension arm and jack it up a bit without making the car unstable.
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #4 ·
hyphon12 - In the end I cut a small slot in the bottom of the bolt and stuck a screwdriver in there. But thanks for the ideas!
 
1 - 4 of 4 Posts
Top