MG & Rover - XPower Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3,703 Posts
Discussion Starter · #1 ·
Developed a misfire on the short journey home tonight and i suspect a faulty coil pack. I am thinking about running her for another day or so then whipping the plugs out one by one to see which one looks the most fouled up which would be a good indicator as to which coil pack is faulty.

Your thoughts on my theory would be much appreciated.

Does anyone know the best place to buy these from?
 

·
Commission Number 000744
Joined
·
2,651 Posts
I got mine from a place called Armstrong Massey via Ebay, genuine LR ones and not bad price, that was for 4 cylinder - assume they'd do the V6 ones too.
 

·
Registered
Joined
·
3,703 Posts
Discussion Starter · #4 ·
Thanks I will most probably be in touch once i find out which one it is.
 

·
Registered
Joined
·
3,703 Posts
Discussion Starter · #5 ·
She started up fine this morning and ran for approx 3miles before starting to splutter. Did the same on the way home at more or less same spot as yesterday.

JASONS I've pm'd you about the ones you have available.
 

·
Registered
Joined
·
3,703 Posts
Discussion Starter · #6 ·
Got rear bank of plugs out on Thursday and found that number 2 was quite pitted. Whilst I was in there I thought I'd renew all the plugs yet again just in case. Anyway, she fired up no problem but once nice and warm started missing again. Got one new coil pack came today courtesy of ebay so I will be changing that in the morning. My money is on number 2 being at fault. The other plugs looked in far better fettle, although number 1 was a tad pitted?
 
1 - 6 of 6 Posts
Top