MG & Rover - XPower Forums banner
1 - 2 of 2 Posts

·
Jonno
Joined
·
667 Posts
Discussion Starter · #1 ·
Hi guys.

ZT CDTI will not start... cranks and cranks but doesn't fire. Ethos showed glow plug fault and CAN-bus. Spray some brake cleaner into airbox and it fires and runs perfect (no smoke, splutters or mis-fires). Once warm you shut it off and try to start, nothing. Once it's warm you clear the codes for glow plugs (as you would expect the engine doesn't need glow plugs once warm) but still doesn't fire on it's own accord. Took inlet mani off and checked glow plug resistance and all are the same and normal except one. Now people may think this is obviously the problem (which also links to the fault code in ECU) but then people say they aren't actually important for the M47R to run... plus it doesn't explain why it doesn't fire from warm?

Done a leak test on injectors and all were consistent and seem fine.

Changed fuel filter.

Checked MAF sensor and all is well. Crank sensor working (needle pulsing and Ethos is showing a reading).

Did some fuel pressure checks in the engine bay. Cranking pressure is low compared to results i were told to look for. Idle pressure is spot on. Pressure at 3k revs is spot on.

Just to reiterate on the symptoms, the car has always been a slow starter for the 4 months i've owned it - taking 2-3 cranks before firing. The morning before it died it took 5-6 cranks. This makes me think it's mechanical rather than a sensor (sensors either work or don't in my eyes). Something mechanical can start to fail over a course of time and then fail altogether?

Any ideas? Apologies if this is long winded. This is my daily transport and i'm stuck between a rock and a hard place without it. Any help would be great!

John
 

·
Registered
Joined
·
219 Posts
I wouldnt worry about the glow plugs. Those TD4 engines only ever have a few faults i know of after working on LR/BMW's. Low pressure pump, Cam sensor, MAF sensor and injectors all tho the MAF doesnt cause a starting fault. If you disconnect the fuel injectors (muti-plugs) and crack it over what rail pressure reading do you get? Also with same test how many cm's of diesel to you get back into leak off bottle pipes should be less than around 20cm's in the pipes
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top